savefs on ext4 partition. 0.6.15 extremely slow

Post here if you found a bug or something really not expected in the program
Post Reply
henrylaw
Posts: 4
Joined: Wed May 01, 2013 6:55 pm

savefs on ext4 partition. 0.6.15 extremely slow

Post by henrylaw » Wed May 01, 2013 7:04 pm

I could have done something wrong but nevertheless "bug reports" seems to be the best topic to post this under, since I know well how to use the program and it's installed already.

I routinely use SysrescueCD to back up ext4 partitions; it's great. Having mounted the remote (NFS) file system I issue a command (on a quad-core CPU) of the form

Code: Select all

fsarchiver -j4 -v savefs /mnt/images/hostname/20130501/20130501.fsa /dev/sda5
I recently upgraded my SysrescueCD so that I'm now using fsarchiver 0.6.15; the savefs is extremely slow. I don't know how long it would take to dump 170GB (approx) because I've never allowed it to get beyond 30%, which takes over two hours. The earlier version of SysrescueCD has fsarchiver 0.6.8 and it backs up the 170GB partition in about twenty minutes.

Am I doing something wrong or is this a bug? Can someone suggest a workround? I much prefer other aspects of the later release of SysrescueCD.

Lazy_Kent
Posts: 53
Joined: Sun Nov 15, 2009 1:08 pm
Location: Moscow, Russia

Re: savefs on ext4 partition. 0.6.15 extremely slow

Post by Lazy_Kent » Wed May 01, 2013 7:38 pm

The latest fsarchiver version is 0.6.17. It is included in SystemRescueCd 3.4.2.

henrylaw
Posts: 4
Joined: Wed May 01, 2013 6:55 pm

Re: savefs on ext4 partition. 0.6.15 extremely slow

Post by henrylaw » Wed May 01, 2013 7:57 pm

Lazy_Kent wrote:The latest fsarchiver version is 0.6.17. It is included in SystemRescueCd 3.4.2.
I'm downloading the latest SysRescueCD (3.5.1) and will try that. Thank you. I suppose I should have thought of that and done it first, hmmm.

henrylaw
Posts: 4
Joined: Wed May 01, 2013 6:55 pm

Re: savefs on ext4 partition. 0.6.15 extremely slow

Post by henrylaw » Thu May 02, 2013 8:06 am

Lazy_Kent wrote:The latest fsarchiver version is 0.6.17.
I tried it this morning using 0.6.17. The savefs crawled to 33% of 150GB in 1h15m (the whole dump is done in 20mins with 0.6.8). I had -v enabled and the file that it was processing was not a large one.

Definitely something wrong, though it could be me. Suggestions for debugging activity?

henrylaw
Posts: 4
Joined: Wed May 01, 2013 6:55 pm

Re: savefs on ext4 partition. 0.6.15 extremely slow

Post by henrylaw » Wed May 08, 2013 7:48 pm

I hope nobody minds my giving this a bump ...

Post Reply