System shutting down with -j multiple thread option

Post here if you found a bug or something really not expected in the program
Post Reply
cercatrova
Posts: 7
Joined: Mon Jan 11, 2010 7:05 pm

System shutting down with -j multiple thread option

Post by cercatrova » Tue Oct 11, 2011 5:10 pm

I've been using fsarchiver 0.6.12 from system-rescue-cd 2.0.1 (32-bit with default options) successfully for some time now on one of my Acer laptops (all ext4 file systems with Ubuntu 10.04), but always without the -j option (I usually run it overnight). The system has an AMD Athlon II X2 M300 2.0 GHz dual-core cpu with 4GB RAM however so I decided to try it today using -j2. It worked with the smaller file systems (less than 1GB) on the drive but when archiving the largest file system (about 60GB) the system shut down at random points during the archive. The actual command was:

fsarchiver savefs -ov -j2 home.fsa /dev/sda5

This was truly a shutdown - I had to press the power button and the system came back up from a cold start. Furthermore it never happened before without the -j option so it's not some kind of power management problem. And indeed after a successful memtest and fsck just in case and a few more unsuccessful tries with -j2 (with both 32-bit and 64-bit system-rescue-cd), I repeated the operation without the -j option and it worked fine as usual.

A related problem was that the resulting archive after the shut downs showed no indication of any problem or that the process had been interrupted - it was just smaller than it should have been. Is there not some kind of completion flag in the archive?

Any ideas? I've never seen a software problem actually shut down a Linux system. By the way, I use -j2 on another Acer laptop that's configured almost identically regarding hardware and software except that it has an Intel Core 2 Duo cpu and it works fine - the largest file system on that one is about 30GB.

It would be great if it worked on the other laptop because the performance difference is significant. Please let me know if more info is needed.

P.S. On another note, I successfully restored an ext4 archive when an Ubuntu upgrade went badly wrong a few months ago - thank you fsarchiver!

Corbin
Posts: 3
Joined: Fri Nov 11, 2011 9:09 am

Re: System shutting down with -j multiple thread option

Post by Corbin » Mon Nov 14, 2011 9:59 am

Here's the issue. Computer is shutting down for no reason.

This is what event viewer is telling me.


- System

- Provider

[ Name] Microsoft-Windows-Kernel-Power
[ Guid] {331C3B3A-2005-44C2-AC5E-77220C37D6B4}

EventID 41

Version 2

Level 1

Task 63

Opcode 0

Keywords 0x8000000000000002

- TimeCreated

[ SystemTime] 2011-11-04T05:01:03.832012800Z

EventRecordID 181496

Correlation

- Execution

[ ProcessID] 4
[ ThreadID] 8

Channel System

Computer AegisVII-PC

- Security

[ UserID] S-1-5-18


- EventData

BugcheckCode 0
BugcheckParameter1 0x0
BugcheckParameter2 0x0
BugcheckParameter3 0x0
BugcheckParameter4 0x0
SleepInProgress false
PowerButtonTimestamp 0


Been looking online, and no solutions have been able to help. Anyone who could help me get this figured out by the release of skyrim would be much appreciated.

cercatrova
Posts: 7
Joined: Mon Jan 11, 2010 7:05 pm

Re: System shutting down with -j multiple thread option SOLV

Post by cercatrova » Thu Apr 12, 2012 2:45 pm

Glad to say that the problem that I was seeing with the -j2 compression option was not fsarchiver's fault - it turned out to be due to the laptop overheating and automatically shutting down. Live and learn...

Post Reply