Page 1 of 1

Trouble archiving a Win7 partition

Posted: Tue Jun 15, 2010 12:19 pm
by floor9
I am using FSarchiver via a SystemRescueCD ISO that is mounted as a loop filesystem by Grub2 at boot. When attempting to archive a Windows 7 NTFS partition (/dev/sda2), I get the following error:

Code: Select all

[errno=5, Input/output error]: oper_save.c#778,createar_save_directory(): cannot lstat64(/tmp/fsa/20100615-071105-00/Windows/assembly/NativeImages_v2.0.50727_32/indexcb.dat)
[errno=5, Input/output error]: oper_save.c#1223,oper_save(): cannot run evaluation createar_save_directory(/tmp/fsa/20400615-071105-00)
removed /mnt/image/test.fsa
When I reboot and try running this under Ubuntu on the same machine, I am getting the same error message (with slightly different timestamps). But when I run FSarchiver from a USB thumb drive with SystemRescueCD installed, I have no problems whatsoever. Everything works perfectly.

I suspect the problem is with my OS or Grub2 configuration and not FSarchiver itself, but I'm hoping someone can offer a suggestion at where I should look. Is this message indicative of a missing module or mis-mounted filesystem or other obvious fix?


Re: Trouble archiving a Win7 partition

Posted: Thu Jun 17, 2010 5:30 pm
by admin
Do you always have the first error on the same file ? To narrow it down you should mount the partition using ntfs-3g directly and see if you can do a stat on that file in the shell. You can also check that your memory is working properly (just run memtest from the menu in sysresccd). I also suspect that you can lack memory when you boot sysresccd with the docache option. You can also check the logs (type "dmesg") to see what the kernel says.

Re: Trouble archiving a Win7 partition

Posted: Tue Jun 22, 2010 5:51 pm
by floor9
Thanks for the response. I have since reinstalled Ubuntu and all is well. This confirms my belief that it was something in the OS and not fsarchiver. All is well.