Page 1 of 1

Trouble restoring file system...

Posted: Thu Aug 17, 2017 7:59 pm
by feffer777
Made a backup of an ext.4 partition living on the 2nd partition of an M2 SSD using like this:

Code: Select all

fsarchiver savefs /path/to/my/ubuntu.fsa /dev/nvme0n1p2
In other words no special modifiers. It ran with no errors. Tried to restore it this way: first mounted the partition and deleted the files...probably not necessary, but I've done this before w/o problem. Then ran fsarchiver with

Code: Select all

fsarchiver restfs /path/to/my/ubuntu.fsa id=0,dest=/dev/nvme0n1p2
It stalled, and after a long wait, I killed the process with Ctl-c. This is the note:

Code: Select all

fs_ext2.c#281,extfs_mkfs(): command [mke2fs /dev/nvme0n1p2  -q  -r 1    -L 'ubunxps'  -b 4096  -I 256  -O has_journal,ext_attr,resize_inode,dir_index,filetype,extent,^journal_dev,flex_bg,^meta_bg,^mmp,large_file,huge_file,sparse_super,uninit_bg,dir_nlink,extra_isize,^bigalloc ] failed with return status=1
oper_restore.c#1280,extractar_filesystem_extract(): cannot format the filesystem ext4 on partition /dev/nvme0n1p2
Not sure what happened. I've done safes and restores with fsarchiver many times before?

Edit: I have linux distros on 3 SSD partitions. After wiping and failing to restore p2, I tried a reboot (did not update Grub, of course), and I was able to reboot into p3. However, I ran gparted and it could not see the SSD at all. This is one of those which plugs into the MB directly via an M2 connection. Before this fiasco, gparted could see it. Currently, # fdisk -l does show the SSD. Just mentioning this if it helps. btw there was no fsarchiver log in /var/log/

Re: Trouble restoring file system...

Posted: Fri Aug 18, 2017 3:20 am
by feffer777
OK, false alarm. I tested a restore on an open partition of this SSD -- no errors and after changing the UUID (it was a dupe) I could update Grub and boot into it. I think I somehow mangled the fsa when I did a Ctl-c to abort the process. I'll check this a little further...